Jump to content
World of Warcraft
  • Announcements

    • TheRock

      User support   07/09/17

      If you do not wish to register on the forum, you can always write on support@wowlegions.ru
    • TheRock

      Minimum server requirements   07/27/17

      System Requirements Apache 2.4.12 or higher PHP Version 7.0.21 or higher MySQL 5.6 or higher Modules for PHP   curl PDO drivers ionCube PHP Loader Should be included - RewriteEngine
      View phpinfo on a demo website  
TheRock

WowLegions - Content management system v.2

Recommended Posts

WowLegions - Content management system v.2


What is already implemented

 

Site

  1. News system
  2. Comment system
  3. Block "new forum topics"

Shop

  1. Categories
  2. The Addition of the product
  3. The Purchase of the product


Personal account:
  1. Registration
  2. Authorization
  3. Password change
  4. Change e-mail
  5. Balance
  6. Balance replenishment
  7. Order history
  8. Using code
  9. Top up your balance with PayPal


Forum
  1. Creating a theme
  2. Response to the topic
  3. To edit the message
  4. Pinned topics
  5. Closed topics
  6. Like the topic


Link
  1. Legion Demo
  2. Old Demo
  3. GitHub Legion
  4. GitHub Old
  5. issues Legion
  6. issues Old
Server Requirements
  1. PHP >= 7.1.3
  2. MySQL >= 5.7.23
  3. OpenSSL PHP Extension
  4. PDO PHP Extension
  5. Mbstring PHP Extension
  6. Tokenizer PHP Extension
  7. XML PHP Extension
  8. Ctype PHP Extension
  9. JSON PHP Extension
Information on installation
  1. To upload files to the server
  2. To load the database dump of the site
  3. Open your website in a browser and follow the instructions

  • Добавил
  • Добавлено
    17.06.2018
  • Категория

 

Share this post


Link to post
Share on other sites

I am having the following error:

Fatal error: Uncaught ReflectionException: Class config does not exist in C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Container\Container.php:767 Stack trace: #0 C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Container\Container.php(767): ReflectionClass->__construct('config') #1 C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Container\Container.php(646): Illuminate\Container\Container->build('config') #2 C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Container\Container.php(601): Illuminate\Container\Container->resolve('config', Array) #3 C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Foundation\Application.php(747): Illuminate\Container\Container->make('config', Array) #4 C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Container\Container.php(1210): Illuminate\Foundation\Application->make('config') #5 C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Log\LogManager.php(406): Illuminate\Container\Container->offsetGet('config') #6 C:\xampp\htdocs\vendor\laravel in C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Container\Container.php on line 767

You can help me?

Share this post


Link to post
Share on other sites
13 часов назад, lohan сказал:

I am having the following error:

Fatal error: Uncaught ReflectionException: Class config does not exist in C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Container\Container.php:767 Stack trace: #0 C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Container\Container.php(767): ReflectionClass->__construct('config') #1 C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Container\Container.php(646): Illuminate\Container\Container->build('config') #2 C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Container\Container.php(601): Illuminate\Container\Container->resolve('config', Array) #3 C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Foundation\Application.php(747): Illuminate\Container\Container->make('config', Array) #4 C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Container\Container.php(1210): Illuminate\Foundation\Application->make('config') #5 C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Log\LogManager.php(406): Illuminate\Container\Container->offsetGet('config') #6 C:\xampp\htdocs\vendor\laravel in C:\xampp\htdocs\vendor\laravel\framework\src\Illuminate\Container\Container.php on line 767

You can help me?

Please download the new version. https://github.com/anonymous33rus/wowlegions

Share this post


Link to post
Share on other sites
В 17.06.2018 в 10:33, TheRock сказал:

Maybe it's missing a file to redirect the pages and images, because the layout of the site is all wrong here, maybe it's the lack of .htaccess.

 

Share this post


Link to post
Share on other sites
19 часов назад, lohan сказал:

Maybe it's missing a file to redirect the pages and images, because the layout of the site is all wrong here, maybe it's the lack of .htaccess.

Email me your domain, I'll check out what you can do about it.

Share this post


Link to post
Share on other sites
Server Requirements
  1. PHP >= 7.1.3
  2. MySQL >= 5.7.23
  3. OpenSSL PHP Extension
  4. PDO PHP Extension
  5. Mbstring PHP Extension
  6. Tokenizer PHP Extension
  7. XML PHP Extension
  8. Ctype PHP Extension
  9. JSON PHP Extension

Share this post


Link to post
Share on other sites

No more on github, ? => a way to put it back ?

I have an old version but I do no understand the logic => my root is public, but is switch to ru-ru (with nothing) doesn't exist (I can harcoded in a php to put en-us but still the directory doesn't exist , any suggestions please ?

Share this post


Link to post
Share on other sites

I have downloaded from yoursite :

just changing the .env :

Fatal error: Uncaught ReflectionException: Class view does not exist in D:\users_sys\games\wow\mangos\www\WowLegions - Content management system\vendor\laravel\framework\src\Illuminate\Container\Container.php:767 Stack trace: #0 D:\users_sys\games\wow\mangos\www\WowLegions - Content management system\vendor\laravel\framework\src\Illuminate\Container\Container.php(767): ReflectionClass->__construct('view') #1 D:\users_sys\games\wow\mangos\www\WowLegions - Content management system\vendor\laravel\framework\src\Illuminate\Container\Container.php(646): Illuminate\Container\Container->build('view') #2 D:\users_sys\games\wow\mangos\www\WowLegions - Content management system\vendor\laravel\framework\src\Illuminate\Container\Container.php(601): Illuminate\Container\Container->resolve('view', Array) #3 D:\users_sys\games\wow\mangos\www\WowLegions - Content management system\vendor\laravel\framework\src\Illuminate\Foundation\Application.php(747): Illuminate\Container\Container->make('view', Array) #4 D:\users_sys\games\wow\mangos\w in D:\users_sys\games\wow\mangos\www\WowLegions - Content management system\vendor\laravel\framework\src\Illuminate\Container\Container.php on line 767

if I launch the install.php

by merging app.zip + fix.zip

Quote


Fatal error: The file D:\users_sys\games\wow\mangos\www\WowLegions - Content management system\vendor\core\Loader.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.